Justin C. Walker on Mon, 26 Jun 2006 00:25:56 +0200

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: Bus error in GP:

Hi, Dave,

On Jun 25, 2006, at 14:55 , David R. Morrison wrote:

On Fri, 9 Jun 2006 17:57:26 -0400, Justin C. Walker <justin@mac.com> wrote:

I get a bus error with the following:

? K=nfinit(y^3-2);
? L=rnfinit(K,x^2+x+1);

  *** rnfinit: bug in GP (Bus Error), please report

I can confirm this, as I was getting the same error today, on pari- gp-2.3.0 during 'make bench'. My experimentation suggests that the error is caused by a compiler bug in XCode 2.2.1 and earlier, and is resolved by switching to XCode 2.3.

Justin, can you confirm? Was there a difference in compilers between your two machines?

Here's the setup: I tried this in the context of SAGE, on Mac OS X 10.4.6, on a PowerPC G4 (2x2.7GHz) and on a MacBook Pro Core Duo (2.16 GHz). I get the same failure in both cases (using 'gp_console ()' in SAGE to talk directly to 'gp').

If I build Pari/gp stand-alone, I do not see the problem.

In all cases, I am using the 2.3.0 release of Pari/gp.

My current guess is that the problem lies with GMP 4.2 (or the gcc compilers that build GMP): for my stand-alone use, I have GMP 4.1.4 installed. SAGE uses GMP 4.2.

I have not yet scraped together the cycles to verify this, so it's only a hunch at this point.

I have not tried rebuilding since upgrading to Xcode 2.3 and the corresponding gcc compilers. I'll try that later today.



Justin C. Walker, Curmudgeon-At-Large
Institute for the Enhancement of the Director's Income
"Weaseling out of things is what separates us from the animals.
 Well, except the weasel."
      - Homer J Simpson